易语言用夜神模拟器实现抖音自动点赞和评论的代码

用夜神模拟器实现抖音自动点赞和评论的代码

实现此功能需要加载精易模块5.6和大漠中文类模块

分辨率设置800x600,窗口大小设置固定。

.版本 2
.支持库 iext
.支持库 iext2
.程序集 窗口程序集_启动窗口
.程序集变量 集_大漠, 大漠中文类
.程序集变量 集_句柄, 整数型
.程序集变量 集_评论内容, 文本型
.程序集变量 集_分割文本, 文本型, , "0"
.子程序 __启动窗口_创建完毕
集_大漠.初始_创建_破解 ()
置随机数种子 ()
.子程序 功能_取句柄, 整数型
.局部变量 局_句柄, 整数型
局_句柄 = 窗口_取句柄 (, , “Qt5QWindowIcon”, “夜神模拟器”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
局_句柄 = 窗口_取句柄 (局_句柄, , “Qt5QWindowIcon”, “ScreenBoardClassWindow”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
返回 (局_句柄)
.子程序 功能_取句柄2, 整数型, , 本子程序采用【精易编程助手】生成,成功返回窗口句柄,失败返回0
.局部变量 局_句柄, 整数型
局_句柄 = 窗口_取句柄 (, , “Qt5QWindowIcon”, “夜神模拟器”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
局_句柄 = 窗口_取句柄 (局_句柄, , “Qt5QWindowIcon”, “ScreenBoardClassWindow”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
局_句柄 = 窗口_取句柄 (局_句柄, , “Qt5QWindowIcon”, “QWidgetClassWindow”)
.如果真 (局_句柄 = 0)
  返回 (0)
.如果真结束
返回 (局_句柄)
.子程序 双击爱心收藏
集_大漠.鼠标_移动 (297, 209)
集_大漠.鼠标_双击左键 ()
.子程序 弹出评论框
集_大漠.鼠标_移动Ex (568, 549, 2, 2)
集_大漠.鼠标_单击左键 ()
.子程序 开始写评论
集_大漠.鼠标_移动Ex (100, 773, 2, 2)
集_大漠.鼠标_单击左键 ()
程序_延时 (500)
文本_投递 (集_句柄, 集_评论内容)
.子程序 点击发送
集_大漠.鼠标_移动Ex (589, 774, 2, 2)
集_大漠.鼠标_单击左键 ()
.子程序 关闭评论框
集_大漠.鼠标_移动Ex (279, 195, 3, 3)
集_大漠.鼠标_双击左键 ()
.子程序 _超级按钮7_被单击
集_句柄 = 功能_取句柄 ()
.判断开始 (集_句柄 = 0)
  透明标签1.标题 = “绑定失败,你是否打开了夜神模拟器?”
.默认
  集_大漠.后台_绑定窗口 (集_句柄, “gdi”, “windows”, “windows”, 0)
  超级按钮1.禁止 = 假
  透明标签1.标题 = “绑定成功( ̄▽ ̄)/”
.判断结束
.子程序 _超级按钮1_被单击
.局部变量 n, 整数型
.局部变量 局_停止标识符, 整数型
局_停止标识符 = 1
.判断开始 (超级按钮1.标题 = “开始执行脚本”)
  .判断开始 (编辑框2.内容 = “”)
    信息框 (“评论内容不要为空哟。”, 64, , )
  .判断 (编辑框4.内容 = “”)
    信息框 (“执行次数不要为空哟。”, 64, , )
  .判断 (编辑框1.内容 = “”)
    信息框 (“间隔时间不要为空哟。”, 64, , )
  .默认
    集_分割文本 = 分割文本 (编辑框2.内容, #换行符, )
    超级按钮1.标题 = “停止执行脚本”
    局_停止标识符 = 1
    信息框 (“脚本开始运行了哟。”, 64, , )
    程序_延时 (1000)
    .计次循环首 (到数值 (编辑框4.内容), n)
      .判断开始 (n = 到数值 (编辑框4.内容))
        超级按钮1.标题 = “开始执行脚本”
      .默认
      .判断结束
      .判断开始 (局_停止标识符 = 0)
        跳出循环 ()
      .默认
      .判断结束
      开始运行脚本 ()
      程序_延时 (到数值 (编辑框1.内容))
    .计次循环尾 ()
  .判断结束
.判断 (超级按钮1.标题 = “停止执行脚本”)
  局_停止标识符 = 0
  超级按钮1.标题 = “开始执行脚本”
.默认
.判断结束
.子程序 开始运行脚本
.局部变量 集_运行次数, 整数型
.局部变量 局_运行次数, 整数型
.局部变量 局_评论标识符, 整数型
.局部变量 i, 整数型
i = i + 1
.判断开始 (i > 取数组成员数 (集_分割文本))
  i = 1
.默认
.判断结束
.判断开始 (选择框3.选中 = 真)
  局_评论标识符 = 取随机数 (1, 取数组成员数 (集_分割文本))
  集_评论内容 = 集_分割文本 [局_评论标识符]
.默认
  集_评论内容 = 集_分割文本 [i]
.判断结束
.判断开始 (选择框1.选中 = 真)
  双击爱心收藏 ()
  程序_延时 (2000)
.默认
.判断结束
.判断开始 (选择框2.选中 = 真)
  弹出评论框 ()
  程序_延时 (2000)
  开始写评论 ()
  程序_延时 (2000)
  点击发送 ()
  程序_延时 (800)
  关闭评论框 ()
  程序_延时 (2000)
.默认
.判断结束
集_大漠.鼠标_移动 (297, 209)
集_大漠.鼠标_滚轮下滚 ()
程序_延时 (4000)
处理事件 ()

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对我们的支持。如果你想了解更多相关内容请查看下面相关链接

时间: 2018-11-23

易语言检测程序是不是在虚拟机中运行的代码

汇编检测虚拟机的代码 .版本 2 .程序集 窗口程序集1 .子程序 __启动窗口_创建完毕, , , .子程序 检测虚拟机, 逻辑型 .局部变量 a, 整数型 .如果 (try_ ()) a = VMWare检测 () try_out () .否则 .如果结束 .如果真 (a ≠ 0) 返回 (真) .如果真结束 .如果 (try_ ()) a = VPC检测 () try_out () .否则 .如果结束 返回 (a ≠ 0) .子程序 VMWare检测, 整数型, , 此函数不能独立在实体机

易语言调用百度API获取IP归属地的代码

常量据表 .版本 2 .常量 查ip地址, "<文本长度: 17>", , {"code":0,"data": 调用百度api获取ip归属地的代码 此功能需要加载精易模块5.6 .版本 2 .程序集 窗口程序集_启动窗口 .子程序 取IP归属地_百度API, 文本型, 公开 .参数 IP地址, 文本型 .局部变量 Json, 类_json .局部变量 返回数据, 文本型 .局部变量 地区, 文本型 CoInitialize (0) 返

易语言调用api枚举网卡名称并且获取信息的代码

DLL命令表 .版本 2 .DLL命令 GetProcAddress, 整数型, "kernel32", "GetProcAddress", , 返回函数地址 .参数 hModule, 整数型 .参数 lpProcName, 文本型 .DLL命令 GetModuleHandle, 整数型, "kernel32", "GetModuleHandleA", , 获取一个应用程序或动态链接库的模块句柄 如执行成功成功,则返回模块句柄

易语言制作语音聊天机器人的代码

常量数据表 .版本 2 .常量 对话前, "<文本长度: 7>", , text":" .常量 对话后, "<文本长度: 2>", , "} .常量 token前, "<文本长度: 16>", , "access_token":" .常量 双撇号, "<文本长度: 1>", , " .常量 apikey, &q

易语言枚举进程所有句柄信息的代码

DLL命令表 .版本 2 .DLL命令 GetCurrentProcessId, 整数型, "kernel32.dll", "GetCurrentProcessId" .DLL命令 GetCurrentProcess, 整数型, "kernel32.dll", "GetCurrentProcess" .DLL命令 RtlMoveMemory_SYSTEM_HANDLE_INFORMATION, , "kernel32

易语言通过计算替换字节实现酷狗音乐缓存文件转MP3的代码

DLL命令表 .版本 2 .DLL命令 创建线程_, 整数型, "kernel32", "CreateThread", , CreateThread建立新的线索 .参数 lpThreadAttributes, 整数型, , 0 .参数 dwStackSize, 整数型, , 0 .参数 lpStartAddress, 子程序指针 .参数 lpParameter, 整数型 .参数 dwCreationFlags, 整数型, , 0 .参数 lpThreadId, 整数

易语言通过句柄名来关闭互斥体实现游戏多开的代码

DLL命令代码 .版本 2 .DLL命令 GetProcessHandleCount, 逻辑型 .参数 hProcess, 整数型 .参数 pdwHandleCount, 整数型, 传址 .DLL命令 DuplicateHandle, 逻辑型 .参数 hSourceProcessHandle, 整数型 .参数 hSourceHandle, 整数型 .参数 hTargetProcessHandle, 整数型 .参数 lpTargetHandle, 整数型, 传址 .参数 dwDesiredAcce

易语言源码被腾讯TP破坏后修复的代码

DLL命令表 .版本 2 .DLL命令 CopyTo_系统信息段, , , "RtlMoveMemory" .参数 Dest, 系统信息段 .参数 Src, 字节集 .参数 Length .DLL命令 CopyTo_SectionInfo, , , "RtlMoveMemory" .参数 Dest, _SectionInfo .参数 Src, 字节集 .参数 Length .DLL命令 CopyFrom_SectionInfo, , , "RtlMoveM

易语言实现快捷登录查询Q币消费记录的代码

常量数据表 .版本 2 .常量 常量1, "<文本长度: 139>", , "accttype": "(.*?)"[\s\S]*?"balance": "(.*?)"[\s\S]*?"info": "(.*?)"[\s\S]*?"pay": "(.*?)"[\s\S]*?"save": "

易语言通过文本解析的方式把C代码转换成易代码

常量数据表 .版本 2 .常量 c, "<文本长度: 759>", , '常量值是一段C代码 C代码转易代码 .版本 2 .支持库 commobj .支持库 iext2 .程序集 窗口程序集_启动窗口 .程序集变量 k, 快速文本对象 .程序集变量 k2, 快速文本对象 .子程序 __启动窗口_创建完毕 .局部变量 z, 字符格式 z.字体大小 = 8 z.字体名称 = "微软雅黑" d1.置默认字符格式 (z) d2.置默认字符格式 (z) d1.内容

易语言无需模块设置自动关闭信息框的代码

DLL命令表 .版本 2 .DLL命令 MessageBoxTimeout, 整数型, "user32.dll", "MessageBoxTimeoutA" .参数 hwnd, 整数型 .参数 lpText, 文本型 .参数 lpCaption, 文本型 .参数 uType, 整数型 .参数 wlange, 整数型 .参数 dwTimeout, 整数型 自动关闭信息框的代码 .版本 2 .程序集 窗口程序集1 .子程序 _弹出信息框按钮_被单击 MessageBox

易语言实现对比版本号检查是否需要更新的代码

版本号对比的代码 .版本 2 .程序集 窗口程序集_启动窗口 .子程序 _检测更新按钮_被单击 .局部变量 结果, 文本型 结果 = 到文本 (版本比对 (当前版本号编辑框.内容, 最新版本号编辑框.内容)) 是否需要更新标签.标题 = 结果 .子程序 版本比对, 逻辑型, , 软件版本号大小对比 .参数 localVersion, 文本型, , 本地版本号 .参数 onlineVersion, 文本型, , 最新版本号 .局部变量 localArray, 文本型, , "0" .局部

易语言调用微信PrScrn.dll文件进行截图的代码

DLL命令表 .版本 2 .DLL命令 GetProcAddress, 整数型, "kernel32", "GetProcAddress", , 返回函数地址 .参数 hModule, 整数型 .参数 lpProcName, 文本型 .DLL命令 GetModuleHandle, 整数型, "kernel32", "GetModuleHandleA", , 获取一个应用程序或动态链接库的模块句柄 如执行成功成功,则返回模块句柄

易语言防止助手探测窗口的代码

DLL命令代码 .版本 2 .DLL命令 CallWindowProcA, 整数型, "user32.dll", "CallWindowProcA", , 限制窗口大小 .参数 前一窗口函数地址, 子程序指针 .参数 窗口句柄, 整数型 .参数 消息值, 整数型 .参数 附加参数1, 整数型 .参数 附加参数2, 整数型 .DLL命令 SetWindowLongA, 子程序指针, "user32", "SetWindowLongA&qu

易语言枚举电脑驱动判断是否存在指定驱动的代码

DLL命令代码 .版本 2 .DLL命令 NtQuerySystemInformation, 整数型, "NTDLL.DLL", "NtQuerySystemInformation" .参数 SystemInformationClass, 整数型 .参数 pSystemInformation, 整数型 .参数 SystemInformationLength, 整数型 .参数 ReturnLength, 整数型, 传址 .DLL命令 CopyMemory, , &qu

易语言枚举所有子窗口讲解

在易语言开发中,有时想直接从一个窗口中拿取 窗口下所有控件的信息,可以用window知道的api入手,但是精益模块有带有这个功能哦. 窗口_枚举所有子窗口() 三个参数: 一.欲寻找控件的窗口句柄 二.查询出来的所有子窗口句柄数组 三.查询的控件类名 对于前两个参数,相信大家都知道,第一个就是 窗口的句柄,第二个就是 句柄的数组(这个是返回的数组)  . 至于第三个参数,楼主和大家一样,第一眼看到有点迷茫,不知道从何下手,比如编辑框控件的类名是什么?标签控件的类名是什么?这里有个好方法,让大家知

C语言 枚举类型(Enum)详解及示例代码

在实际编程中,有些数据的取值往往是有限的,只能是非常少量的整数,并且最好为每个值都取一个名字,以方便在后续代码中使用,比如一个星期只有七天,一年只有十二个月,一个班每周有六门课程等. 以每周七天为例,我们可以使用#define命令来给每天指定一个名字: #include <stdio.h> #define Mon 1 #define Tues 2 #define Wed 3 #define Thurs 4 #define Fri 5 #define Sat 6 #define Sun 7 in

易语言将电脑任务栏透明化的代码

DLL命令表 .版本 2 .DLL命令 寻找顶级窗口, 整数型, "user32", "FindWindowA", , 寻找窗口列表中第一个符合指定条件的顶级窗口(在vb里使用:FindWindow最常见的一个用途是获得ThunderRTMain类的隐藏窗口的句柄:该类是所有运行中vb执行程序的一部分.获得句柄后,可用api函数GetWindowText取得这个窗口的名称:该名也是应用程序的标题) 找到窗口的句柄.如未找到相符窗口,则返回零.会设置GetLastEr

易语言调用TTS语音模块实现文字转换语音功能的代码

DLL命令表 .版本 2 .DLL命令 CoInitialize, 整数型, "ole32.dll", "CoInitialize" .参数 pvReserved, 整数型 .DLL命令 CoUninitialize, , "Ole32.dll", "CoUninitialize", , 在当前线程,关闭COM库,卸载所有加载的DLL的线程,释放线程保持的任何其他资源,并强制关闭所有的线程上的RPC连接. 利用系统自带的TTS

易语言调用墨迹天气实现自动定位获取天气情况的代码

常量数据表 .版本 2 .常量 实况头, "<文本长度: 9>" .常量 实况尾, "<文本长度: 2>" .常量 更新时间头, "<文本长度: 28>" .常量 更新时间尾, "<文本长度: 9>" .常量 温度头, "<文本长度: 28>" .常量 温度尾, "<文本长度: 5>" .常量 空气质量头, &quo

易语言解析音悦台MV提供超清下载地址的代码

音悦台MV地址解析 此功能需要加载精易模块5.6 .版本 2 .支持库 exui .支持库 EThread .程序集 窗口程序集_启动窗口 .程序集变量 标清, 文本型 .程序集变量 高清, 文本型 .程序集变量 超清, 文本型 .子程序 _按钮EX1_左键单击 按钮EX2.可视EX = 假 按钮EX3.可视EX = 假 按钮EX4.可视EX = 假 .判断开始 (编辑框EX1.内容 = "") 信息框EX (, "告警 :", , "先输入MV地址才能解

易语言抓包获得地址实现TP路由器登陆的代码

常量数据表 .版本 2 .常量 协议头, "<文本长度: 310>", , Accept: text/html, application/xhtml+xml, */* Referer: http://地址/userRpm/MenuRpm.htm Accept-Language: zh-CN User-Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0) Accept-En

易语言超级列表框点击表头进行排序的代码

超级列表框排序模块源码 .版本 2 .支持库 iext .程序集 程序集1 .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码 _临时子程序 () ' 在初始化代码执行完毕后调用测试代码 返回 (0) ' 可以根据您的需要返回任意数值 .子程序 _临时子程序 ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中. 注意不要修改本子程序的名称.参数及返回值类型. .子程序 超级列表框排序, 整数型

易语言免费领取ofo小黄车三个月骑乘卡的代码

免费领取ofo小黄车三个月骑乘卡的代码 此功能需要加载精易模块5.6 .版本 2 .支持库 EThread .程序集 窗口程序集_启动窗口 .程序集变量 cookies, 文本型 .子程序 __启动窗口_创建完毕 .局部变量 返回, 文本型 .子程序 _发送按钮_被单击 启动线程 (&发送, , ) .子程序 发送 .局部变量 返回, 文本型 返回 = 编码_URL解码 (到文本 (网页_访问_对象 ("https://san.ofo.so/ofo/Api/activity/monthC