MYSQL拒绝访问报错not allowed to connect
mysql报如下错误,截取部分,
message from server: "Host '****' is not allowed to connect to this MySQL server
1:在登录mysql服务器
2:执行:GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' WITH GRANT OPTION //赋予任何主机访问数据的权限
3:FLUSH PRIVILEGES //修改生效
这样就可以在其它任何的主机上以root身份登录啦!
相关推荐
-
linux mysql 报错:MYSQL:The server quit without updating PID file
1.可能是/usr/local/mysql/data/rekfan.pid文件没有写的权限解决方法 :给予权限,执行 "chown -R mysql:mysql /var/data" "chmod -R 755 /usr/local/mysql/data" 然后重新启动mysqld! 2.可能进程里已经存在mysql进程解决方法:用命令"ps -ef|grep mysqld"查看是否有mysqld进程,如果有使用"kill -9 进
-
mysql报错:MySQL server version for the right syntax to use near type=InnoDB的解决方法
本文实例讲述了mysql报错:MySQL server version for the right syntax to use near type=InnoDB的解决方法.分享给大家供大家参考,具体如下: 一.问题: 工作中使用sql语句建表时,mysql报了如下错误: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right
-
mysql导入sql文件报错 ERROR 2013 2006 2002
今天导入sql总是提示错误 复制代码 代码如下: ERROR 2013 (HY000): Lost connection to MySQL server during query ERROR 2006 (HY000): MySQL server has gone away No connection. Trying to reconnect... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/va
-
Mysql联合查询UNION和Order by同时使用报错问题的解决办法
因此,常常出现这样的错误 复制代码 代码如下: select * from [IND] where INDID>10unionselect * from [IND] where INDID<9 目前为止,还没有出现问 之后,也许有人会用到类似的查询 复制代码 代码如下: select * from [IND] where INDID>10 order by INDID descunionselect * from [IND] where INDID<9 order by INDID
-
phpmyadmin报错:#2003 无法登录 MySQL服务器的解决方法
通过phpmyadmin连接mysql数据库时提示:"2003 无法登录 MySQL服务器"...很明显这是没有启动mysql服务,右击我的电脑-管理-找到服务,找到mysql启动一下,,是不是启动有报错: "无法启动mysql服务 错误1067:进程意外中止 " 然后就baidu google吧,多是说禁远程连接,要改my.ini文件,也有说防火墙的,总之对症下药. 不过同样的报错,导致它的原因并不是都是同样的.这就是看自己的经验和对问题的钻研了,好了不多 说了,
-
MySQL 启动报错:File ./mysql-bin.index not found (Errcode: 13)
Linux下安装初始化完MySQL数据库之后,使用mysqld_safe启动mysql数据库,如下发现,启动失败 [root@SVNServer bin]# ./mysqld_safe –user=mysql& 或 [root@SVNServer bin]# /etc/init.d/mysqld start Starting MySQL. ERROR! The server quit without updating PID file (/data/mysql/AY140208160934776
-
mysql 报错This function has none of DETERMINISTIC解决方案
本文章向朋友们介绍开启bin-log日志mysql报错:This function has none of DETERMINISTIC, NO SQL解决办法, 创建存储过程时 出错信息: ERROR 1418 (HY000): This function has none of DETERMINISTIC, NO SQL, or READS SQL DATA in its declaration and binary logging is enabled (you *might* want t
-
linux下 root 登录 MySQL 报错的问题
最近在centOS 7上,通过yum安装了mysql,安装成功后,使用root登录,出现了如下报错: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) mysql版本为:Ver 14.14 Distrib 5.7.10, for Linux(X86_64) using EditLine wrapper 然而实际上并没有进行过root密码设置(不知道是不是安装过程有被忽略的地方?).
-
MySql报错Table mysql.plugin doesn’t exist的解决方法
一般产生原因是手工更改my.ini的数据库文件存放地址导致的 mysql服务启动时候找不到内置数据库"mysql",找不到那张表,就包了上述错误. 解决办法:将安装目录或之前的目录里面的"mysql"数据库拷贝到新的数据库文件存放目录即可
-
mysql登录报错提示:ERROR 1045 (28000)的解决方法
本文分析了mysql登录报错提示:ERROR 1045 (28000)的解决方法.分享给大家供大家参考,具体如下: 一.问题: 公司linux系统的mysql数据库root用户设置过密码,但常常用命令'mysql -u root -p'登录报错,有时又能登录.登录报错信息为: [root@localhost ~]# mysql -u root -p Enter password: ERROR 1045 (28000): Access denied for user 'root'@'localho
随机推荐
- PHP中使用cURL实现Get和Post请求的方法
- PHP中文汉字验证码
- Javascript获取表单名称(name)的方法
- 详解在Python和IPython中使用Docker
- 脚本的DVD开发
- Photoshop把照片变为高光黑白效果
- 全面解析JS字符串和正则表达式中的match、replace、exec等函数
- Asp.net MVC 对所有用户输入的字符串字段做Trim处理的方法
- 解决wincache不支持64位PHP5.5/5.6的问题(提供64位wincache下载) 原创
- asp短信接口源码 比较简单但也挺实用用的(两个写法)
- 数据库崩溃,利用备份和日志进行灾难恢复
- 微信小程序之仿微信漂流瓶实例
- 用C/C++来实现 Node.js 的模块(二)
- JS实现“隐藏与显示”功能(多种方法)
- php实现网站顶踩功能的完整前端代码
- CSS实现光滑圆角效果
- Javascript在IE和FireFox中的不同表现简析
- Python语言实现获取主机名根据端口杀死进程
- SQL2008的sa账户被禁用其他账户无法连接的快速解决方法
- jquery text()要注意啦
