Pycharm中import torch报错的快速解决方法

Pycharm中import torch报错

问题描述:

今天在跑GitHub上一个深度学习的模型,需要引入一个torch包,在pycharm中用pip命令安装时报错:

于是我上网寻求解决方案,试了很多都失败了,最后在:Anne琪琪的博客中找到了答案,下面记录一下解决问题的步骤:

1、打开Anaconda prompt执行下面命令:

conda install pytorch-cpu torchvision-cpu -c pytorch 等待运行结束。

2、 测试torch是否安装成功

import torch
print(torch.__version__)

如果输出了torch版本号,那么恭喜你,torch安装成功!

3、更改python解释器

我们刚刚用Anaconda下载了torch包,接下来只需要将Pycharm中python的解释器换成Anaconda的python路径即可,具体步骤:
File–Settings–Project:xxx–Project Interpreter–show all–点击“+”添加–System Interpreter–D:\develop\Anaconda3 \python.exe(划线部分换成你自己Anaconda的安装路径即可),到此成功解决Pycharm中import torch的问题。
如果有任何问题,希望各位大佬指正。

在看下另一个朋友分享的解决方案

Pycharm中import torch报错

以下是我分析及解决问题过程

1.没有安装Pytorch:(我的环境是Python3.6+win7+无cuda+Anaconda3)在Pytorch的官网上找到相应的安装方法,即打开Anaconda Prompt命令行,输入命令conda install pytorch-cpu torchvision-cpu -c pytorch,运行等待安装完成,在cmd命令行中测试不报错。

2.在Pycharm中import torch报错,原因项目的解释器路径是Python的安装路径,改为Anaconda的Python的路径即可,具体步骤为,File--Settings--Project:xxx--Project Interpreter--show all--点击“+”添加--System Interpreter--C:\Users\Administrator\Anaconda3\python.exe

问题得到解决。

总结

到此这篇关于Pycharm中import torch报错的快速解决方法的文章就介绍到这了,更多相关Pycharm import torch报错内容请搜索我们以前的文章或继续浏览下面的相关文章希望大家以后多多支持我们!

时间: 2020-03-02

解决PyCharm import torch包失败的问题

Anaconda3-5.1.0-MacOSX-x86_64.pkg 下载安装后,附带安装了pytorch包. 需要将环境调整到新的python3.6目录下. 1.在Project Interpreter选择"Show All..."菜单 Show All... 2.点击"+",新增新的Interpreter 选择 : Add Local... 选择 : System Interpreter 3.选择Anaconda3目录下的python3.6文件. 地址 : /an

解决python3 安装完Pycurl在import pycurl时报错的问题

此次遇到的问题是在import pycurl 时报错 pycurl:libcurl link-time version is older than compile-time version 在网上看了很多解释和方法,但都没有很好的解决和分析这个问题,我先说下自己的过程 1.安装的事centos7 ,默认安装的是python2.7,python3是后使用src安装的,同样先下载了curl-7.61的包和pycurl-7.43的包,应该都是最新的了 2.先make && make instal

导入tensorflow:ImportError: libcublas.so.9.0 报错

错误:ImportError: libcublas.so.9.0: cannot open shared object file: No such file or directory 问题:找不到cuda9.0的版本. 出现该错误的主要原因:cuda未安装或者cuda的版本有问题 这个错误在安装tensorflow时经常会出现,但是在官方的常见问题中没有提到, 如果你使用下面的方法没有解决的话,可以在评论中留言. 对于tensorflow 1.7版本,只接受cuda 9.0(9.1也不可以!),

python 3.74 运行import numpy as np 报错lib\site-packages\numpy\__init__.py

安装完 anaconda 运行如下代码执行不了 import numpy as np import os,sys #获取当前文件夹,并根据文件名 def path(fileName): p=sys.path[0]+'\\'+fileName return p #读文件 def readFile(fileName): f=open(path(fileName)) str=f.read() f.close() return str #写文件 def writeFile(fileName,str):

导入tensorflow时报错:cannot import name 'abs'的解决

一,问题背景 作者在用tensorflow做实验时,import tensorflow忽然报错:cannot import name 'abs'.错误情况如下所示: 这个问题出现的比较新,网上暂时没有太多的讨论. 二,可能原因 对于这个问题,讨论最多的在github上,附上链接:https://github.com/tensorflow/tensorflow/issues/20778 提问者也是遇到了同样的问题: tensorflow官方暂时将这个问题标记为了"待回应". 有网友指出该

导入tensorflow时报错:cannot import name 'abs'的解决

一,问题背景 作者在用tensorflow做实验时,import tensorflow忽然报错:cannot import name 'abs'.错误情况如下所示: 这个问题出现的比较新,网上暂时没有太多的讨论. 二,可能原因 对于这个问题,讨论最多的在github上,附上链接:https://github.com/tensorflow/tensorflow/issues/20778 提问者也是遇到了同样的问题: tensorflow官方暂时将这个问题标记为了"待回应". 有网友指出该

解决windows上安装tensorflow时报错,“DLL load failed: 找不到指定的模块”的问题

最近打算开始研究一下机器学习,今天在windows上装tensorflow花了点功夫,其实前面的步骤不难,只要依次装好python3.5,numpy,tensorflow就行了,有一点要注意的是目前只有python3.5能装tensorflow,最新版的python3.6都不行. 装好tensorflow后,我建议大家不要直接用测试用例进行测试(如果没装好的话出现的错误一般都是:module 'tensorflow' has no attribute 'constant').第一次测试时可以在p

innodb_index_stats导入备份数据时报错表主键冲突的解决方法

故障描述 percona5.6,mysqldump全备份,导入备份数据时报错Duplicate entry 'hoc_log99-item_log_27-PRIMARY-n_diff_pfx01' for key 'PRIMARY' 故障原因 查看了下这个主键应该是MySQL系统库下的系统表innodb_index_stats mysql> show create table innodb_index_stats\G *************************** 1. row ****

Tomcat启动时报错:java.lang.UnsatisfiedLinkError的解决

问题 之前tomcat启动老是报错,虽然不影响项目的启动运行,但是有强迫症的程序员会心里不爽: 如下: 问题分析 由于本机安装的jdk版本与tomcat中使用的jdk版本不一致导致的. 解决方法 后面我把原先tomcat启动环境用的jdk1.7改为了本机安装的jdk1.8就不在报错. 具体过程: 在myeclipse中点击window→preference→在搜索框中输入Tomcat→选择安装的tomcat版本,我这里是选择Tomcat 7.x→点击JDK→在Tomcat 7.x JDK nam

解决Tensorflow安装成功,但在导入时报错的问题

在Mac上按照官网教程安装成功tensor flow后,但在程序中导入时,仍然报错,包括但不限于以下两个错误.对于这种错误,原因主要在于Mac内默认的python库比较老了,即便通过pip命令安装了新的包,python也会默认导入默认位置的包.这时候需要做的就是删除,有冲突的包,对于以下两个错误,就是分别时numpy和six两个包冲突了. 可以在python命令行环境下,通过numpy.version和six.version两个命令查看当前版本,如果与预期的不一致,就可以删掉. 可以通过nump

Python3.5 win10环境下导入kera/tensorflow报错的解决方法

本文实例讲述了Python3.5 win10环境下导入keras/tensorflow报错的解决方法.分享给大家供大家参考,具体如下: 我在win10 Python3.5.2安装keras,然后导入时报错如下: Python 3.5.2 |Continuum Analytics, Inc.| (default, Jul 5 2016, 11:41:13) [MSC v.1900 64 bit (AMD64)] on win32 Type "help", "copyright&

安装pyecharts1.8.0版本后导入pyecharts模块绘图时报错: “所有图表类型将在 v1.9.0 版本开始强制使用 ChartItem 进行数据项配置 ”的解决方法

安装pyecharts1.8.0版本后导入pyecharts模块绘图时报错: "所有图表类型将在 v1.9.0 版本开始强制使用 ChartItem 进行数据项配置 "的解决方法; 作者这里可能仅仅只是针对某些情况,希望对你有所帮助! 安装pyecharts: 对于学习大数据可视化萌新来说我们一般都会使用 pip install pyecharts 命令来安装pyecharts包,因为这个pip命令是最简单快捷的方式,但是使用这个命令一般来说默认安装的是最新版本的包. 当我们安装完成后

在pycharm中使用matplotlib.pyplot 绘图时报错的解决

This application failed to start because it could not find or load the Qt platform plugin "windows" in " ". 百度谷歌了好久都没能解决这个问题都没能解决 开始我以为是缺少windows这个包,但是代码里并没有用到,所以我打断点去看代码到底问题出在哪里 发现问题出在matplotlib上面,我猜想是Qt和matplotlib版本不兼容导致的,于是我卸载了这两个插件