win10系统安装oracle11g时遇到INS-13001环境不满足最低要求解决办法

win10安装oracle 11g,在安装时点击setup.exe之后,出现了:[INS-13001]环境不满足最低要。

解决办法很简单,这是因为版本注册问题,默认oracle 11没有添加win10的注册信息,所以要讲win10的注册信息添加到oracle的配置文件里。打开oracle安装包,找到stage文件夹,找到cvu_prereq.xml文件,用记事本打开可以看到如下内容,在<CERTIFIED_SYSTEMS>标签最后添加如下第二部分。

<CERTIFIED_SYSTEMS>
     <OPERATING_SYSTEM RELEASE="5.0">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="Windows2000"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />
      </ENV_VAR_LIST>
     </OPERATING_SYSTEM>
     <OPERATING_SYSTEM RELEASE="5.1">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="WindowsXP"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />
      </ENV_VAR_LIST>
     </OPERATING_SYSTEM>
     <OPERATING_SYSTEM RELEASE="5.2">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="Windows Server 2003"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />
      </ENV_VAR_LIST>
     </OPERATING_SYSTEM>
     <OPERATING_SYSTEM RELEASE="6.0">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="WindowsServer2008"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />
      </ENV_VAR_LIST>
     </OPERATING_SYSTEM>
     <OPERATING_SYSTEM RELEASE="6.0">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="WindowsVista"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />
      </ENV_VAR_LIST>
     </OPERATING_SYSTEM>
    <OPERATING_SYSTEM RELEASE="6.1">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="Windows 7"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />
      </ENV_VAR_LIST>
     </OPERATING_SYSTEM>
    <OPERATING_SYSTEM RELEASE="6.1">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="WindowsServer2008R2"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />
      </ENV_VAR_LIST>
</OPERATING_SYSTEM>  
     </OPERATING_SYSTEM>
      <OPERATING_SYSTEM RELEASE="6.2">
      <VERSION VALUE="3"/>
      <ARCHITECTURE VALUE="64-bit"/>
      <NAME VALUE="Windows 10"/>
      <ENV_VAR_LIST>
        <ENV_VAR NAME="PATH" MAX_LENGTH="1023" />

      </ENV_VAR_LIST> 

     </OPERATING_SYSTEM>

改动后保存。重新点击setup.exe就可以顺利安装了(如何安装的是32位的,则将64-bit改成32-bit就可以了!)具体oracle完成安装流程参考:http://blog.csdn.net/qq_26442553/article/details/79596962

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持我们。

时间: 2019-09-13

win10 oracle11g彻底删除并重装教程

卸载oracle11g步骤: 1.首先关掉所有oracle的相关服务,然后找到oracle的卸载程序Universal Installer: 然后点击卸载产品,然后点击展开全部,将主目录以外的所有应用全部卸载掉,然后将点击显示空目录,将主目录删掉. 2.删除注册表: 按Windows徽标键和R键,打开运行窗口,输入regedit,打开注册表,依次展开HKEY_LOCAL_MACHINE\SOFTWARE,找到oracle,删除之.  依次展开HKEY_LOCAL_MACHINE\SYSTEM\C

win10 oracle11g安装报错问题集合 附解决方法

本文实例为大家分享了oracle11g安装报错的原因,和对应的解决方法,供大家参考,具体内容如下 注册ocx时出现ole初始化错误或OCX加载错误 问题原因:安装文件不能放在包含空格的文件夹名字中 解决办法:oracle安装的时候最好安装在盘符的根目录下,不要使用中文 ora-00922(缺少或无效选项) 问题原因:配置管理员密码时,采用了数字开头的密码 解决办法:将密码改为英文开头(配置密码时,需要数字.大写英文.小写英文) [ins-32025]所选安装与指定oracle主目录中已安装软件冲

oracle12c安装报错:PRVF-0002的解决方法

./runInstaller 启动图形化报错 PRVF-0002 : Could not retrieve local nodename. 查看了一下报错信息: [root@test68 OraInstall2013-09-06_04-43-39AM]# cat installActions2013-09-06_04-43-39AM.log 后几行报错: SEVERE: [FATAL] PRVF-0002 : Could not retrieve local nodename. Refer as

tensorflow 报错unitialized value的解决方法

Attempting to use uninitialized value mean_squared_error/total 如图: 原因一:使用了tf.metrics.mean_squared_error(labels, predictions) 解决方法: 1.将其换成tf.losses.mean_squared_error(labels, preditions) 或者 2.加一个tf.lacal_variables_initializer() 原因二:将一些节点写在了tf.Session(

perl操作MongoDB报错undefined symbol: HeUTF8解决方法

因为shell操作mongo比较麻烦,只好尝试使用perl操作mongo,perl需要操作mongodb必须先安装相应的驱动,大部分人使用cpan安装,个人觉得太麻烦,使用cpanm安装perl模块. 复制代码 代码如下: # cpanm MongoDB --> Working on MongoDB Fetching http://www.cpan.org/authors/id/F/FR/FRIEDO/MongoDB-0.702.1.tar.gz ... OK Configuring Mongo

node.js请求HTTPS报错:UNABLE_TO_VERIFY_LEAF_SIGNATURE\的解决方法

发现错误 最近在用Nodejs发送https请求时候,出现\"Error: UNABLE_TO_VERIFY_LEAF_SIGNATURE\"的错误,错误如下: events.js:72 throw er; // Unhandled \'error\' event ^ Error: UNABLE_TO_VERIFY_LEAF_SIGNATURE at SecurePair. (tls.js:1381:32) at SecurePair.emit (events.js:92:17) at

解决Window10系统下Node安装报错的问题分析

前言 今天电脑重装了win10系统,在安装Node的过程中出现了下面的问题,下面就和大家分享下用来解决这种问题的小方法. 报错原因 随便问下度娘我们就可以知道,导致报错的原因是由于权限的关系,因此我们只需要使用管理员权限来运行当前Node安装包就可以解决报错问题了. 具体方法 使用管理员权限打开命令行工具并且cd到node安装包的项目文件夹下执行下面代码: msiexec /i package node-v6.9.1-x64.msi 运行指令之后接下来就会自动弹出安装界面,然后我们只需要按照提示

Python使用pip安装报错:is not a supported wheel on this platform的解决方法

本文讲述了Python使用pip安装报错:is not a supported wheel on this platform的解决方法.分享给大家供大家参考,具体如下: 可能的原因1:安装的不是对应python版本的库,下载的库名中cp27代表python2.7,其它同理. 可能的原因2:这个是我遇到的情况(下载的是对应版本的库,然后仍然提示不支持当前平台) 在https://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy中,我下载到的numpy库文件名: n

解决Unixbench安装报错信息的问题

运行环境: Ubuntu 16.04.3 x86_64 在Ubuntu下安装运行Unixbench时,提示报错信息如下 gcc -o ./pgms/ubgears -DTIME -Wall -pedantic -ansi -O2 -fomit-frame-pointer -fforce-addr -ffast-math -Wall ./src/ubgears.c -lGL -lXext -lX11 /usr/bin/ld: /tmp/ccnTgDEZ.o: undefined reference

解决yum安装报错Protected multilib versions的问题

今天在云服务器上装nginx,需要先安装一些依赖库比如zlib,但是安装zlib时候报错. yum install -y zlib zlib-devel (-y 指的是如果需要选yes no的自动y)下面是报错 Protected multilib versions: zlib-1.2.7-17.el7.x86_64 != zlib-1.2.7-15.el7.i686 原因是因为多个库不能共存,不过更新的话也并不行,但是可以在安装命令后面加上 --setopt=protected_multili

Tomcat报错: JDBC unregister 解决办法

 Tomcat报错: JDBC unregister 解决办法 摘要: The web application [web application] registered the JDBC driver [net.sourceforge.jtds.jdbc.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has be