mysql错误处理之ERROR 1665 (HY000)
ERROR 1665 (HY000)
【环境描述】
msyql5.6.14
【报错信息】
执行SQL语句的时候报错:
ERROR 1665 (HY000): Cannot executestatement: impossible to write to binary log since BINLOG_FORMAT = STATEMENTand at least one table uses a storage engine limited to row-based logging.InnoDB is limited to row-logging when transaction isolation level is READCOMMITTED or READ UNCOMMITTED.
【报错原因】
innodb的事务隔离级别是read commited或者read uncommited模式时,binlog不可以使用statement模式。
【解决方法】
不重启mysql实例的解决方法:
set global binlog_format=mixed
重新建立的会话session中binlog format会变为mixed模式。
相关推荐
-
mysql错误处理之ERROR 1786 (HY000)
ERROR 1786 (HY000) [环境描述] msyql5.6.14 [报错信息] 执行create table ... select的时候遇到报错: 复制代码 代码如下: db1 [test] [23:01:58]> create tablelgmnr_bak select * from lgmnr; ERROR 1786 (HY000): CREATE TABLE ... SELECTis forbidden when @@GLOBAL.ENFORCE_GTID_CONSISTENCY
-
MySQL错误ERROR 2002 (HY000): Can't connect to local MySQL server through socket
在安装好了MySQL之后,使用了新的配置文件后,MySQL服务器可以成功启动,但在登陆的时候出现了ERROR 2002 (HY000): Can't connect to local MySQL server through socket,即无法通过socket连接到mysql服务器,同时提供了socket文件的位置.下面是这个问题的描述与解决办法. 1.故障现象 复制代码 代码如下: [root@SZDB mysqldata]# mysql -uroot -p123456 Warning: U
-
mysql error 1130 hy000:Host'localhost'解决方案
ERROR 1130 (HY000): Host 'localhost' is not allowed to connect to this MySQL server www.jb51.net 出现原因: mysql只有一个root用户,修改root密码后选了MD5,提交后,重新 登陆出现"Host 'localhost' is not allowed to connect to this MySQL server..." 尝试另一个mysql库中的user表,覆盖,不行,估计是版本不
-
MySQL ERROR 2013 (HY000)错误解决方法
当通过 TCP/IP 连接 MySQL 远程主机时,出现 ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 104 . 如果是在linux shell命令行中直接打 mysql 命令,能够顺利连上 MySQL,执行查询语句也比较正常,但如果执行 STOP SLAVE; 命令时就随机出现 ERROR 2013 (HY000): Lo
-
mysql中一个普通ERROR 1135 (HY000)错误引发的血案
今天接到测试人员反应,测试环境前端应用程序无连接mysql数据库,登录mysql服务器,查看错误日志,发现有如下报错: ERROR 1135 (HY000): Can't create a new thread (errno 11);if you are not out of available memory,you can consult the manual for a possible OS-dependent bug 第一反应感觉可能是跟ulimit限制连接数有关,文件描述符不够用.接下
-
详解远程连接Mysql数据库的问题(ERROR 2003 (HY000))
在我们用客户端及其远程连接服务器Mysql数据库的过程中,容易出现下面问题: 问题代码代码 ERROR 2003 (HY000): Can't connect to MySQL server on '192.168.0.19' (111) ERROR 2003 (HY000): Can't connect to MySQL server on '192.168.0.19' (111) 这个 原因就是Mysql数据库的默认配置文件my.cnf(linux下)中的bind-address
-
PHP下使用mysqli的函数连接mysql出现warning: mysqli::real_connect(): (hy000/1040): ...
背景:把mysql换成mysqli时出现,连接数过多,其实际上并不是,原因是我挪动了一下php的sock文件位置导致,因这几个socket修改没有修改完全,于是出现了too many connections ,从mysql里show processlist并没有发现真的有连接,其实用tshark抓下包估计能看到(http://justwinit.cn/post/7458/),并没有发出请求,而估计是mysqli的客户端自己报出来的,别看这个问题小,搞了老半天,都想重新安装Php了,发现原来是路径
-
mysql错误处理之ERROR 1665 (HY000)
ERROR 1665 (HY000) [环境描述] msyql5.6.14 [报错信息] 执行SQL语句的时候报错: ERROR 1665 (HY000): Cannot executestatement: impossible to write to binary log since BINLOG_FORMAT = STATEMENTand at least one table uses a storage engine limited to row-based logging.InnoDB
-
解决MySQL启动报错:ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)
这个错误是新手经常会遇到的,本文主要介绍如何修复ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061) 解决方案: 1.登录到安装Mysql的主机,打开cmd命令行工具,执行命令mysql -uroot -p,报出下面所描述的错误: 2.在开始菜单中找到计算机管理,在计算机管理中找到[服务],在服务检查是否存在Mysql服务: 3.如果[步骤2]中找不到Mysql服务需要手动安装Mysql服务,安装命令为m
-
mysql启动时出现ERROR 2003 (HY000)问题的解决方法
一.问题描述 在启动MYSQL时出现问题:"ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)",情况如图: 二.问题分析 从错误的提示中可以看出MySQL服务没有启动,因此只需要启动MySQL服务就可以了. 三.问题解决 直接采用net start MySQL 就可以启动MySQL服务,但是输入命令后仍然出现错误: 可以看到错误提示:"服务名无效",说明不存在MySQL服
-
MySQL服务器登陆故障ERROR 1820 (HY000)的解决方法
故障现场:登陆到MySQL服务器,不管你执行什么命令都报这个错 mysql> show databases; ERROR 1820 (HY000): You must reset your password using ALTER USER statement before executing this statement. mysql> use test; ERROR 1820 (HY000): You must reset your password using ALTER USER st
-
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock'
错误信息: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) 出现问题原因: 有可能是 my.cnf 配置文件中设置了 [mysqld] 的参数 socket ,而没有设置[client]的参数socket mysql.sock 文件有什么用: mysql 支持 socket 和 TCP/IP 连接.那么 mysql.sock 这个文件有什么用呢?连接local
-
ERROR 1862 (HY000): Your password has expired. To log in you must change it using a .....
错误信息: ERROR 1862 (HY000): Your password has expired. To log in you must change it using a client that supports expired passwords 出现问题原因: 可能是你在安装 MySQL过程中,通过mysqld --initialize 初始化 mysql 操作后,生成临时密码后,没有直接进行 MySQL连接,中途重启服务或者重启机器等,导致密码失效问题 解决方式: 1.修改 my.
随机推荐
- Jquery弹出窗口插件 LeanModal的使用方法
- Linux 入门常用命令 password — 修改密码,改变用户
- Android 取得状态栏、任务栏高度的小例子
- 通过dom4j解析xml字符串(示例代码)
- java 正则表达式基础,实例学习资料收集大全 原创
- Android实现三级联动下拉框 下拉列表spinner的实例代码
- setTimeout自动触发一个js的方法
- CentOS服务器下安装Webmin管理系统的步骤
- js控制CSS样式属性语法对照表
- 15个jquery常用方法、小技巧分享
- 关于安卓手机微信浏览器中使用XMLHttpRequest 2上传图片显示字节数为0的解决办法
- mysql 查询表中平均分最低的班级
- 详解android webView独立进程通讯方式
- java更改图片大小示例分享
- spring cloud 之 客户端负载均衡Ribbon深入理解
- Java设计模式之代理模式原理及实现代码分享
- 使用maven profile指定配置文件打包适用多环境的方法
- Python流程控制 if else实现解析
- layui lay-verify form表单自定义验证规则详解
- vue + element-ui的分页问题实现
