Android Studio 报错“app:processDebugResources"解决方法

Android Studio 报错“app:processDebugResources"解决方法

Android Studio项目Build的时候报了这么一个错误:

Error:Execution failed for task ':app:processDebugResources'.
> com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException:
 Process 'command 'D:\Java\as-sdk\build-tools\23.0.0_rc3\aapt.exe'' finished with non-zero exit value 1

网上的答案,大部分都是说build.gradle的兼容包和compileSdkVersion配置不对引起的,不过之前项目运行的时候是完全没问题的,也没有修改过gradle文件,所以应该不是这个原因引起的,仔细一看,在这个报错上面,有提示错误信息~~

有了错误信息那就好找了。一般是资源文件冲突,可以clean一下项目,检查资源有没有缺少或重复~~像我这边的错误就是activity_home is already define,也就是重复了,但是有意思的是,我res/layout目录下明明就只有一个文件,居然重复...而且,更有意思的是,我把这个xml删了居然可以,也就是没有xml布局了,但是还能运行和显示....可想而知是Studio的缓存,clean一下工程便是~~

感谢阅读,希望能帮助到大家,谢谢大家对本站的支持!

时间: 2017-07-09

Android Studio报错Manifest merger failed with multiple errors

1.Error:Execution failed for task ':XXXX:processDebugManifest'. > Manifest merger failed with multiple errors, see logs 原因: AS的Gradle插件默认会启用Manifest Merger Tool,若Library项目中也定义了与主项目相同的属性(例如默认生成的android:icon和android:theme),则此时会合并失败,并报上面的错误. 解决方法有以下2种:

Android Studio启动报错Java 1.8 or later is required的解决方法

错误描述 在公司电脑上运行Android Studio 2.2已经有一段时间了,但是自己的笔记本上还是用的Android Studio 1.5,今天晚上下了一个Android Studio 2.2压缩包,解压后启动Android Studio 2.2就报错了,错误如下所示: Unsupported Java Version : Cannot start under Java 1.7.0_04-b22 : Java 1.8 or later is required. 分析错误 查看当前电脑的Jav

详解Androidstudio3.0 关于Gradle报错的问题(小结)

前言 升级Android Studio to 3.0 canary 1版本后,之前一个正常的Project,一直报错,报错内容如下 Error:Failed to complete Gradle execution. Cause: The version of Gradle you are using (3.3) does not support the forTasks() method on BuildActionExecuter. Support for this is available

Android Studio 报错failed to create jvm error code -4的解决方法

安装完 Android Studio 后启动,却报错如下: 复制代码 代码如下: failed to create jvm error code -4 这一般应是内存不够用所致,解决方法参考如下. 打开 Android Studio 安装目录下的bin目录,查找并打开文件 studio.exe.vmoptions,修改代码: 复制代码 代码如下: -Xmx512m 为 -Xmx256m 保存后应即可正常打开了.

Android Studio报错unable to access android sdk add-on list解决方案

一.问题 初次安装Android Studio,启动后,报错如下: unable to access android sdk add-on lis 如图: 二.原因 AS启动后,会在默认路径下检测是否有Android SDK,如果没有的话,就会报上述错误. 三.解决方案 3.1 主动设置SDK 如果本机有Android SDK的话,可以点击cancel跳过,在下一个界面手动选择本地SDK目录就可以了. 3.2 跳过检测 在Android Studio的安装目录下,找到\bin\idea.prop

Android Studio使用Kotlin时,修改代码后运行不生效的解决方法

问题现象 前段时间升级 Android Studio 3.1.3+ 版本后,决定尝试使用 Kotlin 做 APP 开发看看.结果却发现,修改 String 资源后,"运行",修改的内容没有生效.一开始以为只是 String 资源是这样,于是试了下 kt 文件,结果发现"运行"也不能生效. 但是先 clean 了,再"运行",却可以正常编译出来.查了好久发现是 New Module 后,Run/Debug Configurations不完整所致.

Python3安装模块报错Microsoft Visual C++ 14.0 is required的解决方法

问题一:安装模块时出现报错 Microsoft Visual C++ 14.0 is required,也下载安装了运行库依然还是这个错误 解决: 1.打开Unofficial Windows Binaries for Python Extension Packages(http://www.lfd.uci.edu/~gohlke/pythonlibs/),这里面有很多封装好的Python模块的运行环境 2.找到所需要下载的模块文件对应版本进行下载. 如,需要下载Pymssql,本机安装是32位

解决eclipse启动时报错Failed to create the Java Virtural Machine.问题的方法

最近在学习android的开发搭建环境时,在网上下载了一个最新的eclpse,在启动的时候报错:Failed to create the Java Virtural Machine. 翻译一下,其意思就是说打开eclipse的失败原因是创建java虚拟机失败! 一般在启动的时候,出错,基本上除了虚拟机出错,就是jdk配置出错. 问题截图: 看原来的配置文件eclipse.ini的内容: 看最后一行"-XX:MaxPermSize=512M"改为256即可. 在看看找不到jdk启动报错的

MongoDB添加仲裁节点报错:replica set IDs do not match的解决方法

背景: 由于历史原因,某个MongoDB副本集只有一主一从双节点,无法满足自动故障转移要求,需要配置一个仲裁节点. 原有节点192.168.10.20:27017,192.168.10.21:27017,现在准备在20上配置一个新节点27018当做仲裁 在当前主节点上执行 repset:PRIMARY> cfg={_id:"repset", members:[{_id:0, host:'192.168.10.20:27017', priority:1},{_id:2, host:

Vue 报错TypeError: this.$set is not a function 的解决方法

报错场景:将APi中得到的response数据,用Vue$set()使数据动态响应 报错代码: methods: { textTranslate: function (text, to) { $.ajax({ url: 'http://openapi.youdao.com/api', type: 'post', dataType: 'jsonp', data: { q: text, appKey: this.appKey, salt: this.salt, from: this.from, to