node版本下报错build: `vue-cli-service build`问题及解决

目录
  • node版本下报错build: `vue-cli-service build`
  • node相关报错问题
    • 问题一:node-sass npm ERR! command failed
    • 问题二:npm ERR! gyp info it worked if it ends with ok
    • 问题三:Node Sass version 6.0.1 is incompatible with ^4.0.0.
    • 问题四:卸载node,再安装其他版本
  • 总结

node版本下报错build: `vue-cli-service build`

用vue cli3.0生成vue项目时,运行项目出现报错build: `vue-cli-service build`,serve: `vue-cli-service serve`

最后查看发生安装的node -v版本时v12.0,node版本不稳定造成的,所以通过nvm切换到node -v v8.11.2版本,再次运行就可以了。

1. 下载安装nvm:

2. 通过nvm下载安装node8.11.2版本:nvm install v8.11.2。

3. 通过nvm切换node版本为v8.11.2:nvm use 8.11.2。

node相关报错问题

问题一:node-sass npm ERR! command failed

解决:

1、删除 npm uninstall node-sass

2、安装 npm install node-sass

问题二:npm ERR! gyp info it worked if it ends with ok

npm ERR! gyp info using node-gyp@3.8.0
npm ERR! gyp info using node@16.11.1 | win32 | x64
npm ERR! gyp ERR! configure error
npm ERR! gyp ERR! stack Error: Command failed: E:\Python37\python.EXE -c import sys; print “%s.%s.%s” % sys.version_info[:3];

解决:

1、npm i -g cnpm --registry=https://registry.npm.taobao.org

问题三:Node Sass version 6.0.1 is incompatible with ^4.0.0.

解决:版本不配套,安装时不要加版本号,因为会自动匹配对应电脑上安装node的版本

1、删除 npm uninstall node-sass sass-loader

2、安装 npm install node-sass sass-loader

问题四:卸载node,再安装其他版本

later version of Node.js is already installed. setup will now exit

解决:

1、打开环境变量编辑窗口 删除框起来的path对应的npm 和 node

2、用msi方式再次安装其他版本时会自动弹出remove之前的node,remove-finish后再次双击msi安装文件,安装新的版本

以上 情况单独出现都不是个事,但同时出现就是我自己作的,两个项目,项目较老,对版本有要求,node有要求,安装了两个不同位数不同版本的node后就出现了以上多个问题,最终解决:

1、node版本问题看报错,降到报错提示的版本

2、卸载安装多个node安装问题四处理

3、项目中的node-sass sass-loader总是会出现版本不对应的错误,删除node-modules,还有删除package.json中相关的,因为npm install会按照里面的版本安装,如果和node的版本对应不上就报错,按照node装sass按照问题三,如果按照项目sass装node参照问题四

4、按装多个版本的node,利用替换环境变量就可以,但是在启动不同的项目npm 的版本也要注意,如果安装npm install 版本号 -g后,就有可能出现问题,即使可切换node,但是原先可以npm跑的项目出现问题;

总结

以上为个人经验,希望能给大家一个参考,也希望大家多多支持我们。

(0)

相关推荐

  • Node.js调用fs.renameSync报错(Error: EXDEV, cross-device link not permitted)

    在写一个文件上传的功能时候,调用fs.renameSync方法错误 出错 代码所在如下: function upload(response,request){ console.log("upload called"); var form = new formidable.IncomingForm(); console.log("about to parse"); form.parse(request, function(error, fields, files) {

  • node.js报错:npm ERR code EPERM的解决过程

    目录 1 完整错误 2 错误详解 2.1 修改npm全局安装: 2.2 导致该安装问题的原因 2.3 修复方法 3 运行测试 总结 1 完整错误 npm ERR! code EPERMnpm ERR! syscall opennpm ERR! path D:\NodeJS\node_cache\_cacache\tmp\7bbab18enpm ERR! errno EPERMnpm ERR! FetchError: Invalid response body while trying to fe

  • NodeJS开发人员常见五个错误理解

    Nodejs 诞生于 2009 年,由于它使用了 JavaScript ,在这些年里获得了非常广泛的流行.它是一个用于编写服务器端应用程序的 JavaScript 运行时,但是 "它就是JavaScript" 这句话并不是 100% 正确的. JavaScript 是单线程的,它不是被设计用来实现要求可伸缩性的服务器端上运行的.借助 Google Chrome 的高性能 V8 JavaScript 引擎, libuv 的超酷异步 I/O 实现以及其他一些刺激性的补充, Nodejs 能

  • 使用Mysql5.x以上版本出现报错#1929 Incorrect datetime value: '''' for column ''createtime''的快速解决方法

    我的MySQL安装后,保存删除表数据总是出现#1929 Incorrect datetime value: '' for column 'createtime' 的报错提醒,导致不能删除表里数据: 原因分析: 5以上的版本如果时期时间是空值应该要写NULL: 官方解释说:得知新版本mysql对空值插入有"bug", 要在安装mysql的时候去除默认勾选的enable strict SQL mode 那么如果我们安装好了mysql怎么办了,解决办法是更改mysql中的配置 my.ini

  • Mysql5.7及以上版本 ONLY_FULL_GROUP_BY报错的解决方法

    近期在开发过程中,因为项目开发环境连接的mysql数据库是阿里云的数据库,而阿里云的数据库版本是5.6的.而测试环境的mysql是自己安装的5.7.因此在开发过程中有小伙伴不注意写了有关group by的sql语句.在开发环境中运行是正常的,而到了测试环境中就发现了异常. 原因分析:MySQL5.7版本默认设置了 mysql sql_mode = only_full_group_by 属性,导致报错. 其中ONLY_FULL_GROUP_BY就是造成这个错误的罪魁祸首了,对于group by聚合

  • python xmind 包使用详解(其中解决导出的xmind文件 xmind8可以打开 xmind2020及之后版本打开报错问题)

    pip install xmind 使用 場景 xmind8 可以打开 xmind2020 报错 main_fest.xml(xmind8 打开另存后 更改后缀为.zip 里边包含META-INF/manifest.xml) ** 将xmind文件修改后缀为zip ---->解压---->放入main_fest.xml ->压缩为zip ->修改后缀为xmind** import xmind import os import re import shutil import zipf

  • 使用Mysql5.x以上版本出现报错#1929 Incorrect datetime value: '''' for column ''createtime''的快速解决方法

    我的MySQL安装后,保存删除表数据总是出现#1929 Incorrect datetime value: '' for column 'createtime' 的报错提醒,导致不能删除表里数据: 原因分析: 5以上的版本如果时期时间是空值应该要写NULL: 官方解释说:得知新版本mysql对空值插入有"bug", 要在安装mysql的时候去除默认勾选的enable strict SQL mode 那么如果我们安装好了mysql怎么办了,解决办法是更改mysql中的配置 my.ini

  • python报错: 'list' object has no attribute 'shape'的解决

    numpy.array可使用 shape.list不能使用shape. 可以使用np.array(list A)进行转换. (array转list:array B B.tolist()即可) 补充知识:Pandas使用DataFrame出现错误:AttributeError: 'list' object has no attribute 'astype' 在使用Pandas的DataFrame时出现了错误:AttributeError: 'list' object has no attribut

  • Laravel 5.4中migrate报错: Specified key was too long error的解决

    前言 大家都知道,我们经常做项目都团队协作开发,每个人都在自己本地的数据库,如果你曾经出现过让同事手动在数据库结构中添加字段的情况,数据库迁移可以解决你这个问题. 不仅如此,在线上部署的时候,也避免了手动导入数据库或手动修改数据结构的麻烦,数据迁移帮你方便的维护着数据结构. 但方便的同时也会伴随着一些问题,下面这篇文章将详细给大家介绍关于Laravel5.4中migrate报错Specified key was too long error的解决方法,下面话不多说了,来一起看看详细的介绍吧. 发

  • PHP正则替换函数preg_replace()报错:Notice Use of undefined constant的解决方法分析

    本文实例讲述了PHP正则替换函数preg_replace()报错:Notice Use of undefined constant的解决方法.分享给大家供大家参考,具体如下: 环境错误级别:error_reporting =E_ALL 某天我在研究一下php下的正则替换函数perg_replace(), 示例: 代码: $subject="2222<b>a</b>2222fff222222222A22222"; $pattern = "/(a)/e&q

  • 安装Docker Desktop报错WSL 2 installation is incomplete的问题(解决报错)

    报错描述 我们安装Docker Desktop的时候,他会问我们是否需要使用WSL2(基于Windows的Linux子系统),如果我们不适用,就会使用Hyper-v虚拟机运行,不过相比于虚拟机,子系统在性能方面更加出色.在我们选择使用WSL2之后,并且我们也确定打开了如下图所示的Windows功能(如果没有打开,请先百度如何打开wsl.) 还是会出现一个下图所示的报错. 解决报错 更加报错提示,猜测可能是我们使用的wsl2版本老了,需要我们自己手动更新一下,我们根据提示去微软官网下载最新版的ws

  • Nginx报错104:Connection reset by peer问题的解决及分析

    目录 问题解决 应用部署环境 现象 解决 过程 最终解决 问题分析 连接重置 Tomcat 的 Connector Nginx 104 类似问题解决思路 总结 问题解决 应用部署环境 语言:java 框架:ssm web容器:tomcat 负载:nginx 外层代理:F5 现象 根据客户需求对接一个停车缴费的功能,发布到生产环境之后发现,少量账单同时支付没有问题,一旦同时支付的账单数量超过某个值,就会出现网路连接问题,稳定复现. 解决 过程 首先查看了应用的日志,发现用户提示网络异常的时候,服务

  • 关于报错IDEA Terminated with exit code 1的解决方法

    本人亲测,在使用IDEA使用Maven模板创建项目或者在当前项目中New Project,Maven的以下三个配置参数会重置使用C:\Users\ZSAndroid\.m2的默认maven下载方式. Maven home path(Maven安装路径) User settings file(Maven下载使用的settings.xml) Local repository(Maven本地仓库,settings.xml下载存放资源的目录) 如果在IDEA构建项目时遇到下面这样的报错IDEA Term

随机推荐

其他